Acceso tabla ARP estática en MitraStar HGU GPT-2541GNAC b38

Acceso tabla ARP estática en MitraStar HGU GPT-2541GNAC b38

(Antes de todo perdonad el duplicado, lo publiqué en el foro de ADSL y no en el de fibra)

 

Buenas noches. Hoy me instalaron fibra en casa con el router MitraStar HGU GPT-2541GNAC, la versión parece ser la b38 (Versión Firmware: ES_s00.00_g001_100VNJ0b38_2).

 

En casa tengo unos pcs que necesito "despertar" a través de WAN (WOW) y para eso es necesario acceder a la tabla ARP y añadir de forma estática las MAC y asignarlas a las IPs de los dispositivos.

 

El WOL funciona bien con todos, así como "suspenderlos" dentro de la LAN. Pero el WOW no funciona con algunos (en cambio el "suspenderlos" sí que funciona).

 

Esto me pasó anteriormente con otras compañías y routers y al final la solución era la misma siempre, añadir a la tabla de ARPs de manera estática la MAC y la IP. Pero en este router no encuentro la opción y soy incapaz.

 

He leído varios hilos y veo que con la b31 se puede acceder vía telnet, pero con la b38 no se puede acceder (una pena porque podría programar algún script que añadiese al a tabla arp). Vía web  no veo opción para añadir a la tabla ARP (pero sí para asignar una IP estática según la MAC, pero esto no es lo mismo que lo que quiero hacer yo y no lo soluciona).

 

He leído un hilo (https://comunidad.movistar.es/t5/Soporte-T%C3%A9cnico-de-Fibra-%C3%93ptica/Modificar-tabla-arp-mitra...) donde parecía que había una solución pero me descargo el fichero de configuración y no encuentro la etiqueta "Autoexec" así que no puedo añadir nada. De todas formas el router no es el mismo...

 

Por favor, ¿alguien puede ayudarme? ¿Tenéis pensado desde movistar sacar alguna actualización que permita el acceso vía telnet?

 

Muchas gracias y un saludo.

Mensaje 1 de 15
3.417 Visitas
14 RESPUESTAS 14

Buenas @jcmartinez1982

 

El HGU GPT no tiene nada que ver con el HGW, sí, los dos son de Mitrastar, pero lo que vale para uno no vale para otro.

 

Los equipos de Movistar hasta la fecha no tienen en la interfaz Web posibilidad de añadir/eliminar entradas ARP estáticas, con lo que hasta que lo quieran implementar, no hay mucho más que rascar.

 

Respecto a que otras formas hacerlo... bueno, es posible, pero me temo que posiblemente te vas a ir sin poder solucionar nada, o con suerte sí...

 

En el pasado, con el HGU Mitrastar pude también modificar la tabla ARP, pero son muchas actualizaciones desde entonces. Al contrario que con el ASKEY, del HGU Mitra si dije como acceder a la shell en su día. En cualquier caso eso no te serviría de mucho. Actualmente es más que posible que se pueda acceder al Mitrastar por SSH o por telnet, aunque sea a la shell reducida, y desde dicha shell ES POSIBLE (o era al menos) añadir ARP estáticos. Pero al igual que antes, los cambios se pierden al iniciar.

 

Existe alguna opción como expuse para el HGW y que incluso los cambios persistan?? Sí, pero hace ya tiempo que decidí no publicar cierto tipo de info, no por nada, sino porque cada vez que lo he hecho en la siguiente actualización lo han arreglado, y al final el que se ha ido fastidiando soy yo y el resto de compañeros, y a mi hacerme más complicado cada vez buscar otras vías de hacerlo :).

 

Prueba por SSH por si aun se puede, que se debería. Otra opción, siempre podrías intentar un mapeo de puertos a la dirección de Broadcast de tu LAN



Por privado solo asuntos privados, para lo demás la comunidad."El conocimiento nace del desacuerdo"
Mensaje 2 de 15
3.399 Visitas

Buenas tardes

 

yo me encuentro en el mismo punto que el compañero para poder configurar una entrada permanente en la tabla ARP (que me permita encender mi DS215j de manera remota). Tengo implementado el resto de pasos como redireccionar el puerto a la IP del equipo, el acceso a través de DDNS, etc. Lo he probado modificando la tabla ARP a través de una conexión SSH local y me funciona correctamente (modificar la tabla ARP y luego el WOW para encender el NAS).

 

El problema es que cuando el router se apaga la configuración ARP se pierde... por lo que deja de funcionar. He realizado las siguientes pruebas:

- editar el archivo de configuración con la entrada Autoexec, tal y como se comentaba en otros hilos, editando el archivo en Notepad++ y respetando los retornos de carro de linux.

- tb he probado ha editar la tabla ARP a través de una conexión SSH y hacer save

- he intentado ejecutar el comando /sbin/arp -s, pero a través de SSH no lo permite (shell reducida).

 

Todas las pruebas que he realizado han sido infrustuosas. Por lo que quedo a la espera de más información para poder proceder con las acciones pertinentes si las hubiera. Mi modelo de router es

GPT-2541GNAC con FW ES_s00.00_g001_100VNJ0b38_2

Etiquetas (7)
Mensaje 3 de 15
3.352 Visitas

Hola @OmarHachmiouneRaposo

 

A este tipo de configuraciones desde la comunidad no podemos dar soporte. Te dejamos el hilo abierto para que los demás usuarios te puedan echar una mano.

 

Saludos!!! Marco.A-Movistar

 



Si necesitas soporte técnico en averías de Móvil, Fijo, Movistar+ o Internet Fijo (cobre o fibra), puedes acceder a nuestro apartado de Soporte Técnico o rellenar este formulario. También puedes contactar con nosotros llamando al 1002.

 Si necesitas contratar Fibra Ópticacomprobar tu cobertura Adsl y Fibrao ver información sobre la instalación de la fibra visita nuestra página ADSL y Fibra en movistar.es 

Solución aceptada.png
Mensaje 4 de 15
3.345 Visitas

Buenas @OmarHachmiouneRaposo

 

Como ya he dicho, no se puede de forma oficial. En el mejor de los casos puedes acceder por shell reducida y añadir las ARP, pero en cuanto reinicies el Router los ajustes se van a perder. Extraoficialmente se puede como he dicho, pero también los motivos por los cuales no lo he publicado, si lo hiciese, en la b38+ lo habrían corregido posiblemente para variar.

 

Así que me temo que hasta que no implementen en la interfaz web la opción, o cambie las políticas de Movistar al respecto... poco se puede hacer.

 

Intentar un mapeo a la dirección de broadcast a ver si hay suerte



Por privado solo asuntos privados, para lo demás la comunidad."El conocimiento nace del desacuerdo"
Mensaje 5 de 15
3.334 Visitas
El problema de reenviar el paquete a la direccion de broadcast es que cualquier equipo con Wow configurado va a encenderse sin necesidad de ello...

Menuda
Mensaje 6 de 15
3.319 Visitas

Si compañero, me temo que así es...



Por privado solo asuntos privados, para lo demás la comunidad."El conocimiento nace del desacuerdo"
Mensaje 7 de 15
3.311 Visitas

Hola. Gracias a todos por vuestras aportaciones. Lo siento por tardar en contestar, pero entre reyes, niños, regalos, etc... no he tenido tiempo para responder ni probar demasiado.

 

Probé lo que dijo Theliel y por SSH funciona, pero como dice Omar cuando reinicias se pierde la configuración. La verdad que en otros routers que he tenido (tanto neutros como de operadora) cuando tenía que añadir la ARP a la tabla luego al reiniciar se perdía esa configuración osea que estoy en la misma situación que antes. El caso es que cuando abrí el hilo ni si quiera sabía como añadirlo.

 

Lo de hacer WOW por broadcast lo descarto porque se me encenderían todos los equipos, pero si tienes uno (o pocos) quizás fuera buena opción.

 

Así que mi opción para solucionarlo ahora mismo sería tener una tarea programada, o un script con cron, que cada x tiempo (15 minutos por ejemplo) se ejecutase y añadiese a la tabla de arp de forma estática. Así si se va la luz o se reinicia el router, sé que a los 15 minutos lo tengo otra vez puesto. El problema es que no voy a dejar un ordenador encendido 24/7 para que solo haga esa tarea... tengo un router neutro que ahora mismo lo tengo en modo repetidor que quizás pueda hacer esa labor... seguiré investigando...

 

De todas formas muchas gracias por vuestras respuestas. Y ójala al equipo de Movistar le diera por facilitar el acceso a éste tipo de configuraciones, nos facilitaría mucho la vida a los usuarios no tan básicos pero tampoco profesionales. Desde luego no sé que podemos romper añadiendo de forma estática esta información y guardándola para que cuando se reinicie esté ahí. Pero supongo que serán políticas de Movistar y creo que poco podemos hacer.

 

Lo dicho, muchas gracias. Y de todas formas si encuentro alguna otra forma de hacerlo actualizaré el hilo.

Mensaje 8 de 15
3.249 Visitas

Yo quería plantear una duda.

 

Desde el mes de septiembre he estado conectándome a mi PC vía WOW. Para poner mi dirección MAC como permanente ligada a la IP, accedía al router a través de putty con la instrucción que @Theliel había explicado en algún post antiguo. La cuestión es que desde que empezó el año ya no puedo hacerlo. Bueno, sí que puedo poner la entrada como permanente, pero en el momento en el que reinicio el ordenador la entrada desaparece de la tabla ARP.

 

¿Sabéis si ha habido algún cambio en el firmware o algo últimamente? ¿Es subsanable?

 

¡Muchas gracias!

Mensaje 9 de 15
3.185 Visitas

Hola jcrevilla.

 

Pues yo tengo la fibra y el router mitrastar desde el 4 de enero, así que antes no sé como se haría la cosa...

 

Yo lo más que he llegado es conectarme por SSH (no por telnet) como explicó Theliel. Así ya podía insertar a mano las entradas. Tenía ganas de pillarme una Raspberry para trastear así que me la pillé y he estado intentando hacer un script que conecte por ssh cada x tiempo y que meta las entradas que me hacen falta de forma estática... al final he desistido porque el ssh que tiene el MItrastar no sé que tendrá que al principio pone "Failed to read file" y no he conseguido que ningún script me haga algo... Paso de seguir trasteando con el router, no lo ponen fácil.

 

Al final lo que hice es que como la Raspberry no tengo pensada apagarla nunca pues por SSH accedo a ella y si que lanzo unos scripts que me hacen el WOL a la máquina que quiera. Desde luego seria mejor meterlas en ARP estática, pero yo ya no sé qué armas utilizar.

 

Lo que sí he detectado es que cuando metes una entrada permanente (0x6 cuando haces arp show) al rato (no sé cuanto... 5, 15, 30 minutos) desaparece y se queda como "temporal" (0x2). Yo creo que no tiene que ver con el reinicio del ordenador, pero tampoco te lo puedo asegurar. La versión que tengo yo es la b38.

 

Un saludo y suerte.

Mensaje 10 de 15
3.163 Visitas

Buenas @jcmartinez1982 / @jcrevilla

 

Ya de por sí no es totalmente trivial automatizar scripts por SSH, pero en este caso concreto es aun más complicado dado que lo das con SSH no es una shell real, es una interfaz intermedia, con lo que no valen los modos "normales" para interactuar con la interfaz. Se puede hacer, pero no es un proceso que digamos "directo", lo más cómodo sería usar Python.

 

Respecto que te has percatado que la entrada desaparece pasado X, sin tener un Mitra a mano, no puedo asegurarte nada. Podría tener un fallo en la firmware que elimina la entrada, podría ser otro equipo quien la elimina, podría ser simplemente que pasa a otro estado... es imposible saberlo



Por privado solo asuntos privados, para lo demás la comunidad."El conocimiento nace del desacuerdo"
Mensaje 11 de 15
3.142 Visitas

Buenas @Theliel

 

El router solo lo uso yo, nadie más tiene acceso a él. La prueba la hice en apenas 2 minutos. Agregué entrada a la tabla ARP. Pasó a permanente. Reinicié el PC y al volver a acceder ya no estaba. Volví a agregarla nuevamente. Lo comprobé y estaba como permanente. Reinicié y otra vez había desaparecido.

 

Cosas a destacar:

- También me sale "Failed to read file" en el putty, pero la entrada la agrega como permanente...

- Siempre he tenido la IP fija en mi PC. Pero ahora, al hacerlo, el router no reconoce el nombre de mi ordenador en la lista DHCP. Tengo que poner la IP automática en las opciones del adaptador para que en la configuración del router reconozca mi ordenador con su nombre.

 

Un saludo.

Mensaje 12 de 15
3.098 Visitas

Mapeando la dirección de broadcast solo se encenderá el equipo que contenga la MAC de la petición de WOL, así que sería la opción válida al no tener acceso a la tabla ARP, el problema es que tampoco funciona la ip de broadcast, si alguien sabe como hacerla funcionar que lo ponga aquí

Mensaje 13 de 15
2.398 Visitas

Hola ARMALSU bienvenid@ a la Comunidad Movistar:

 

Comprobamos que ningún usuario a aportado ninguna solución desde tu consulta, dejamos el hilo abierto durante unos días a la espera de que algún usuario te de alguna solución.

 

Saludos. M. Carmen.



Si necesitas soporte técnico en averías de Móvil, Fijo, Movistar+ o Internet Fijo (cobre o fibra), puedes acceder a nuestro apartado de Soporte Técnico o rellenar este formulario. También puedes contactar con nosotros llamando al 1002.

 Si necesitas contratar Fibra Ópticacomprobar tu cobertura Adsl y Fibrao ver información sobre la instalación de la fibra visita nuestra página ADSL y Fibra en movistar.es 

Solución aceptada.png
Mensaje 14 de 15
2.269 Visitas

Hola ARMALSU:

 

Al no tener respuesta por parte de ningun usuario, procedemos a cerrar el hilo, quedamos a tu disposición para cualquier consulta o gestión.


Gracias por utilizar la Comunidad Movistar.

 

Saludos. M. Carmen.



Si necesitas soporte técnico en averías de Móvil, Fijo, Movistar+ o Internet Fijo (cobre o fibra), puedes acceder a nuestro apartado de Soporte Técnico o rellenar este formulario. También puedes contactar con nosotros llamando al 1002.

 Si necesitas contratar Fibra Ópticacomprobar tu cobertura Adsl y Fibrao ver información sobre la instalación de la fibra visita nuestra página ADSL y Fibra en movistar.es 

Solución aceptada.png
Mensaje 15 de 15
2.242 Visitas