Imposible poner VG-8050 como AP

SEG
Yo probé el VDSL
Yo probé el VDSL
Imposible poner VG-8050 como AP

Hola, a ver si me echar un cable.

 

Tengo el HGU Askey como principal. De ahí a un switch que reparte en varias plantas. Y finalmente tengo un VG-8050 para una de las plantas.

El VG-8050 solo quiero que haga de switch por cable, y de AP para la wifi.

Pero no hay manera, no me da IP dentro del rango.

 

Los pasos que sigo son:

1) reset de fabrica

2) Deshabilitar DCHP

3) Deshabilitar WPS

4) Cambiar IP a una fija. 

5) En wifi he probado hasta sin establecer contraseña.

 

Solo consigo internet por cable porque el portátil tiene IP Fija, pero claro, no es la solución, tendría que poner también ip fija en todas los dispositivos que utilicen wifi.

 

Obviamente los cables están bien (probado con tester), y he grabado y reiniciado varias veces.

 

¿Podéis ayudarme?

 

pd: me han comentado de ponerlo en modo bridge, pero creo que no es el caso, yo no quiero repetir wifi, solo es un AP más.

 

Gracias de antemano.

Mensaje 1 de 11
3.573 Visitas
10 RESPUESTAS 10
Theliel
Yo probé el VDSL

Buenas @SEG

 

En realidad, lo que tendrías que hacer sí es ponerlo en Bridge, pero lo que es un Bridge real, no lo que llaman por ahí estos Routers a "Wireless Bridge", que son dos cosas totalmente diferentes. Ese "Wireless Bridge" que hacen referencia suele ser usar WDS para expandir WIFI, siempre he dicho que usar ese nombre es llevar a confusión.

 

En cambio, configurar el Router como Bridge completo sería lo que realmente necesitas, de ese modo podrías conectar cualquier cosa a sus 4 puertos LAN y por WIFI, y este a su vez estaría conectado por su WAN al LAN del principal. Que puedas configurarlo o no de este modo ya queda en manos tuyas, no tengo ese modelo por aquí. Pero te doy unas nocioens básicas que puedes seguir.

 

Tienes dos modos de hacerlo, la buena y la mala, en función de lo que te permita hacer el Router.

 

La buena: Bridge

 

La opción buena y real y 100% guay es poner el Router en Bridge... en Bridge la interfaz WAN con el resto del Router. Para esto tendrías que eliminar cualquier interfaz WAN que esté previamente en el Router, y configurar una nueva interfaz WAN que sea Bridge. Una vez realizado esto, por asegurarse, deshabilitar DHCP y el FW del Router, y poner la configuración WIFI como se quiera.

 

Funciona porque al estar la interfaz WAN como bridge, todo lo que entra por el puente que forma el swicth con el AP del Router, lo pasa directamente a WAN y de WAN a ellos, incluyendo las peticiones DHCP y demás.

 

La mala: Falso Bridge

 

Este escenario se usa cuando el Router no te permite configurarlo como Bridge su interfaz WAN. Para un Router doméstico en condiciones normales tiene dos partes muy muy diferenciadas: WAN y LAN. son dos mundos totalmente diferentes. No basta con configurar dos cosas y ala, todo funciona bien... por eos es necesario configurar la interfaz WAN como bridge para hacer algo así. Si esto no es posible, no se podrá usar el puerto WAN del Router para alimentar la conexión, pero hay otra opción.

 

En vez de conectar el principal desde uno de sus LAN a WAN del secundario, se conecta el principal desde uno de sus LAN a otro LAN del secundario, NO WAN. El secundario tiene un Switch integrado así que todo lo qeu conectes a una de sus bocas está en Switch.

 

En este escenario es imperativo deshabilitar DHCP en el secundario, y para evitar conflictos usar una red difernte siempre a la del principal.

 

La ventaja es que este modo funciona casi siempre, la desventaja, entre otras cosas, es que pierdes como es natural un puerto del Switch



Por privado solo asuntos privados, para lo demás la comunidad."El conocimiento nace del desacuerdo"
Mensaje 2 de 11
3.552 Visitas
SEG
Yo probé el VDSL
Yo probé el VDSL

Gracias @Theliel

Me ha quedado bastante claro, lo probaré.

Erroneamente pensaba que Bridge era para cuando hacías puente, siendo el bridge siempre el pimero. Pero ahora entiendo que no, que aunque sea el segundo router, también es un puente.

 

La opción mala es la que  no sé por qué, no me funciona, pues lo he hecho otras veces siempre con el puerto LAN, claro.

 

Probaré la opción buena.

 

Gracias.

Mensaje 3 de 11
3.530 Visitas
Theliel
Yo probé el VDSL

Buenas @SEG

 

Bueno, es que "Bridge" es "Puente". En su definición más básica, un Bridge no es más que un dispositivo software/hardware (históricamente hardware) que une dos o mas segmentos de red, usando para ello niveles 1 y 2 del modelo OSI.

 

Cuando se hace Bridge en WAN, por tanto, lo que se hace es "conectar" directamente lo que entra por WAN al Switch interno del Router. Del mismo modo que el propio AP del Router hace Bridge con el Switch.

 

Es lo mismo cuando decimos que ponemos el principal en Bridge, lo que dices de que pensabas que era erronamente, lo que queremos hacer en ese comportamiento es "pasar" WAN a la LAN. No estabas equivocado, simplemente estabas interpretando sólo una versión simplista de ello, pero es lo mismo.

 

Si la opción "mala" no te funciona, es posible que el secundario, en este caso el VG-8050, tenga reglas en el FW interno que filtren los Query/Reply DHCP que sean entrantes al Switch (en realidad no es el Switch sino al puente que conforman AP+Switch, llamado por lo general br0). En este escenario el principal no tiene problema en proveer con DHCP, pero las peticiones o nunca le llegan o estas no pueden replicarse en el Switch.

 

En la opción buena esto no puede pasar, el secundario conecta al principal por WAN, con lo que este tipo de filtros no existen, los equipos de la LAN secundaria mandan las peticiones al Router, que a su vez está en puente con WAN que a su vez las manda al principal, y de vuelta. Una de las muchas ventajas de la opción "buena" frente a la "mala"



Por privado solo asuntos privados, para lo demás la comunidad."El conocimiento nace del desacuerdo"
Mensaje 4 de 11
3.513 Visitas
SEG
Yo probé el VDSL
Yo probé el VDSL
Hola @theliel.

De nuevo muchas gracias por tus indicaciones.

He puesto el secundario como bridge "bueno".
He conseguido que haga de switch, y también funciona la wifi pero con un problema, llega entre 1 y 6 Mb solamente (por cable si llega las 300mb)
Tiene una oscilación entre esos valores muy abrupta, sube a 6, baja repentinamente a 1, y así....

Con lo cual sospecho que por wifi no está haciendo de AP sino de repetidor, y cómo llega mal la señal wifi del primario al estar en otra planta (por eso necesito un AP), pues repite lo que le llega.

Es mi sospecha.

Los valores 802.1P Priority y 802.1Q VLAN ID los estoy poniendo a -1 -1, pues había leído que era la mejor manera, pero creo que debería cambiarlo para que haga de AP y no de repetidor.

¿Sabes qué debería poner?

Y luego otra duda, al configurar el modo bridge me indica IGMP Snooping DISABLED. Creo que es otro problema, pues necesito que ese AP lo tenga activado para filtrar el tráfico multicast. Todos los router y switch de mi casa los tengo con esa opción activada.
En este AP en realidad no le conectaré el DECO de Movistar TV, pero no descarto ponerle VLC al PC que sí está conectado (siempre por cable), por eso pienso que debería tener el snooping activado para que no me ocasiones saturaciones en la red wifi que utilizan los otros dispositivos.

Mil gracias.
Mensaje 5 de 11
3.478 Visitas
Theliel
Yo probé el VDSL

Buenas @SEG

 

La "oscilación" de la velocidad WIFI puede ser por mil cosas, empezando por interferencias de cualquier tipo, a fin de cuentas es WIFI

 

No puede actuar como repetidor porque no tiene ese modo, y porque para que funcione de repetidor se debe de configurar expresamente para ello, ya fuese repetidor real o WDS. Por ponerlo en Bridge no se configura automáticamente WIFI para funcionar como repetidor :).

 

Sobre VLANID y PRIO, poco tiene que ver aquí, no tiene nada que ver con que sea mejor o peor. Simplemente (seguramente), ponerlo en -1 -1 lo que hace es deshabilitarlo, es decir... no usar VLAN, que es lo normal, aun así en Bridge no creo que usase VLAN

 

Por lo general IGMP Snooping no es una opción propia de WAN, sino del Switch, debería de permitirte habilitarlo indistintamente. En cualquier caso, por lo general, WIFI suele tener su propio IGMP Snooping, llamado de forma habitual Wireless Multicast Forwarding o cosas así



Por privado solo asuntos privados, para lo demás la comunidad."El conocimiento nace del desacuerdo"
Mensaje 6 de 11
3.467 Visitas
SEG
Yo probé el VDSL
Yo probé el VDSL

Hola @Theliel

 

Gracias nuevamente por tus instrucciones.

He estado varios días intentándolo y algo se me escapa.

 

También he seguido las instrucciones de @banyosoto en múltiples post, que indica:

 

Marcamos la opción Bridging, en la casilla Enter 802.1P Priority [0-7] escribimos 1 y en la casilla Enter 802.1Q VLAN ID [0-4095]escribimos 6, después pulsamos el botón Next

 

Si lo pongo en 1 y 6, no tengo internet ni por cable, y ya no me deja acceder a la IP del router desde la red (para acceder tengo que conectar físicamente el pc al router, y a éste quitarle la conexión WAN). Yo creo que esta opción debe ser para poner un router neutro después del comtrend. No es mi caso, como comenté, ya tengo un HGU como primario que gestiona todo, luego un switch con snooping que reperte las conexiones por cable, y por último el comtrend, el cual solo lo quiero como switch y como AP Wifi, siendo así:

 

HGU ASKEY (primario y gestiona todas conexiones) --> SWITCH TP-LINK TL-SW105 --> COMTREND VG-8050 (AP) --> PC

 

Si lo pongo en -1 -1, tengo internet en cable y wifi, pero wifi entre 1 y 6 Mb, subiendo y bajando de una manera demasiado abrupta, y eso que en mi zona apenas hay interferencias (4-5 wifis). Lógicamente cambio de canal por probar, y estoy delante del router, a 10 cms...

En este modo, probé a poner el brandwith 20/40, por defecto viene 20, y se cargó la mitad de campos de configuración, los ocultó de repente, y no me dejó volver atrás (tengo que hacer reset y volver a empezar).

Cuando tenía el VG-8050 como principal sí iba la wifi (unos 100mb), eso sí, poco alcance, por eso me pasé al HGU.

 

 

Así sigo, no doy con el problema.

No sé si la mejor opción es guardarlo, y comprarme otro switch con snooping, al cual ponerle un AP WIFI de mercado....

 

La verdad que todos los post que he encontrado al respecto siempre hablan de poner el VG-8050 como puente para otro router neutro que viene después, y en mi caso es algo distinto, el puento lo pongo al final solo para hacer de AP.

 

Sigo investigando, me trae de cabeza, aunque me está sirviendo para aprender gracias a ti !!!!  :smileyvery-happy

 

 

Mensaje 7 de 11
3.434 Visitas
Theliel
Yo probé el VDSL

Buenas @SEG

 

A ver... es lo que te he dicho anteriormente.

 

Como Bridge REAL no hay taggeo de las VLAN. Cuando marcas el tráfico con VLAN estableciendo el VLANID en X, lo que estás haciendo es que el Router sólo "pase" ese tipo de tráfico, pero es que ese tipo de tráfico nunca va a pasar, porque el tráfico que le llega, todo él, no está tageado. Es decir, tiene que estar como -1-1, es decir, sin taggear.

 

Esto no debería de afectar en nada a WIFI, es una cuestión interna. El caso de WIFI casi seguro es una cuestión de interferencias



Por privado solo asuntos privados, para lo demás la comunidad."El conocimiento nace del desacuerdo"
Mensaje 8 de 11
3.419 Visitas
SEG
Yo probé el VDSL
Yo probé el VDSL

Gracias @Theliel

Me ha quedado claro.

Voy a hacer pruebas con -1 -1 a ver si consigo ver qué pasa.

Por si acaso borraré las 3 interfaces que vienen por defecto y dejaré solo la de Bridge que cree yo, aunque por lo que comentas no debe afectar en nada, pues pasará de ellas al ser Bridge Total.

 

s2

Mensaje 9 de 11
3.404 Visitas
SEG
Yo probé el VDSL
Yo probé el VDSL

Hola @Theliel

 

Tras diversas pruebas, siempre en modo -1 -1, me he dado cuenta que al VG-8050 en ese modo no le gusta que toques la configuración avanzada de la wifi.

 

- Si no tocas nada de configuración, llegan unas 15-20 Mb por wifi (bastante poco teniendo en cuenta que el canal está libre y que estoy a 10 cm del router).

- Si tocas la configuración de la wifi, pasa a enviar máximo 1Mb y además desaparecen la mitad de campos de la pantalla. Ya no puedes volver atrás, y toca resetear de fábrica.

 

Gracias.

Mensaje 10 de 11
3.377 Visitas
Theliel
Yo probé el VDSL

Buenas @SEG

 

Pues algún problema con la firmware del Router que al ponerlo en Bridge pierde el... "acceso" a los ajustes WIFI o similar, es raro desde luego. No debería de afectar en nada



Por privado solo asuntos privados, para lo demás la comunidad."El conocimiento nace del desacuerdo"
Mensaje 11 de 11
3.346 Visitas