Mitrastar HGW-2501GN-R2 como adaptador de teléfono analógico (ATA)

Mitrastar HGW-2501GN-R2 como adaptador de teléfono analógico (ATA)

Buenas noches,

 

Me gustaría utilizar el Mitrastar HGW-2501GN-R2 como un adaptador de teléfono ATA conectado al router principal ASUS RT-AC1200G+.

 

He probado una pequeña variación de la configuración que mentan en la Ref. 1, y conseguido transferir señal al teléfono, puedo llamar y recibir, sin embargo, en ningún caso se escucha el tono de llamada ni a ninguno de los interlocutores. Resumo lo que he hecho:

 

Mitrastar:

- Desactivar todos los perfiles WAN de Internet e Imagenio.

- Desactivar VLAN de Voz. Dejar este perfil activado.

- Cambiar la IP a otro nivel de red (diferente al 192.168.1.1 que sería el Asus), por ejemplo 192.168.2.1.

- En configuración SIP, no toco nada.

- Reiniciar.

 

En el Asus:

- Configurar Triple VLAN de Movistar.

- Datos de Imagenio del Mitrastar al Asus.

- Direccionamiento dinámico de VOIP y DNS automático.

- Habilitar IGMP Snoopy.

- Ruta DHCP: Microsoft y RFC3442.

 

Conexiones:

- Eth1 del ONT a WAN del Asus.

- LAN de Asus a WAN del Mitrastar.

- Telefono a RJ11 del Mitrastar.

 

¿Qué tengo que tocar en el Mitrastar para que funcione bien el teléfono sin tener que gastarme dinero en adaptadores?

 

Nota: Comentar que SÍ O SÍ, sólo me vale esta configuración (ONT < ASUS < MITRA < TELF) por tema de distribución física de las habitaciones.

 

Referencia 1: https://comunidad.movistar.es/t5/Soporte-Fibra-y-ADSL/Mitrastar-HGW-2501GN-R2-modo-Bridge-problema/m...

Mensaje 1 de 19
3.114 Visitas
18 RESPUESTAS 18

Buenas @fodoto 

 

Creo que en el otro hilo explicaba como hacerlo, y veo errores en tu configuración.

 

Yo lo que haría sería 1º borrar todas las WAN, y crear una sola en Bridge para evitar NAT. La IP al Router se la asignaba en la misma red del asus, si el asus está en 192.168.1.0/24 le ponái 192.168.1.2. En caso de que el bridge no fuese posible, la configuraba como Eth y manual en 192.168.1.2 mascara 255.255.255.0 y puerta de enlace 1.0

 

Llegado este punto hay que configurar el ATA del Mitrastar para que use la interfaz WAN recién creada y listo. Por cuestiones obvias y habituales deshabilitar DHCP, el FW, WIFI y demás.

 

Si el Asus está correctamente configurado en triple vlan y funciona SIP, que eso sería otra cuestión, el Mitra tendría que poder usar el ATA. Encualquier caso me parece un chisme muy grande para usarlo solo de ATA 🙂



Por privado solo asuntos privados, para lo demás la comunidad."El conocimiento nace del desacuerdo"
Mensaje 2 de 19
3.096 Visitas

Hola @Theliel , gracias por la rápida respuesta. Tenía esperanza en que me contestaras 😊.

 

Sí, desde luego el cacharro es grandote, pero ya que lo tengo, le busco uso aunque sea sólo para la clavija. Mañana aplico todo lo que me has explicado y te comento. Gracias de nuevo compañero!

 

Mensaje 3 de 19
3.088 Visitas

Yo estoy en las mismas, pero con un Amper EG-663.

 

En un principio, configuré en el router principal las dos redes (VoIP y WAN, no tengo IPTV), y también las rutas dinámicas que envía Movistar para la red VoIP, de tal forma que los clientes en la red LAN pudieran acceder tanto a internet como a la red VoIP.

 

En el Amper configuré únicamente la red WAN como cliente DHCP, y comprobé que desde éste tenía acceso tanto a internet como a los servidores de VoIP. En teoria esto debería funcionar sin más, ya que desde el Amper hay pleno acceso a todo lo necesario; pero el caso es que no funciona, y no entiendo el motivo.

 

El segundo intento ha consistido en configurar dos VLANs en uno de los puertos ethernet del router principal (el que conecta con el Amper): la VLAN 3 conecta directamente con la VLAN 3 del puerto WAN, y la VLAN 1 conecta con la red LAN. En el Amper, la configuración de VoIP es la original (con el cliente de DHCP en la VLAN 3), y la red WAN es ahora cliente DHCP en la VLAN 1.

 

De momento, parece que está funcionando correctamente, aunque en alguna ocasión he tenido cortes en el sonido de las llamadas. Pero no tengo claro si es culpa del montaje o del router (hasta hace dos días tenía la telefonía aprovisionada en la ONT).

Mensaje 4 de 19
3.083 Visitas

Buenas @eduperez 

 

En el Amper no puedo decirte porque no lo he tenido nunca, no sé si existirá  algún problema interno o no. Generalmente no hace falta tocar ninguna ruta porque el Router ya las tiene internamente, y por lo general es tirarlas por WAN establecido, que a su vez llegaría al que está arriba. Aunque dependiendo de la configuración interna si podría ser necesario revisarlas y configurarlas de forma estática.

 

No suelen ser soluciones perfectas porque los equipos de Movistar aun cuando los intentas usar como bridge completos hay mucha "porquería" debajo que no pude quitarse o configurarse, con lo que a veces hay que pelearse. En el caso del Mitrastar creo recordar que en alguna ocasión tuve que habilitar también ALG SIP... pero lo digo de memoria, hace ya tiempo que no toqueteo eso.



Por privado solo asuntos privados, para lo demás la comunidad."El conocimiento nace del desacuerdo"
Mensaje 5 de 19
3.079 Visitas

En el Amper no puedo decirte porque no lo he tenido nunca, no sé si existirá  algún problema interno o no. Generalmente no hace falta tocar ninguna ruta porque el Router ya las tiene internamente, y por lo general es tirarlas por WAN establecido, que a su vez llegaría al que está arriba. Aunque dependiendo de la configuración interna si podría ser necesario revisarlas y configurarlas de forma estática.

No sé si nos hemos entendido...

 

A través de la red VoIP, Movistar anuncia[*] por RIP una ruta, que es la que da acceso a los servidores de SIP. El router que gestiona esa red debe aceptar esa ruta, o de lo contrario no hay  acceso a los servidores de SIP. 

 

[*] Leí en algún sitio que Movistar estaba cambiando la forma de funcionar de la red VoIP, pero mi router no tiene ninguna ruta estática, y yo sigo recibiendo el anuncio de la ruta.

 

No suelen ser soluciones perfectas porque los equipos de Movistar aun cuando los intentas usar como bridge completos hay mucha "porquería" debajo que no pude quitarse o configurarse, con lo que a veces hay que pelearse. En el caso del Mitrastar creo recordar que en alguna ocasión tuve que habilitar también ALG SIP... pero lo digo de memoria, hace ya tiempo que no toqueteo eso.


El Amper que tengo es famoso por no soportar el modo bridge; al menos, antes Movistar los cambiaba cuando alguien se quejaba de este tema. El mío sí tiene la opción de ponerlo en modo bridge, pero nunca lo he probado, porque yo lo tengo como router secundario.

Mensaje 6 de 19
3.072 Visitas

Buenas @eduperez 

 

Para que lleguen las rutas por RIP el Router superior debería de estar enviándolas hacia abajo, y no tengo claro que por defecto lo haga así, no sé que Router tendrás arriba. En lo personal suelo establecerlas de forma estática, realmente tanto para VoIP como IPTV, se puede crear una o dos rutas y listo.

 

Sobre el amper especifico ya te digo que no puedo decir mucho, ni idea si no se puede poner en bridge, me temo. Con el Mitrastar si pude hacer hace tiempo la configuración que se indica sin mayores problemas

 

Saludos.



Por privado solo asuntos privados, para lo demás la comunidad."El conocimiento nace del desacuerdo"
Mensaje 7 de 19
3.023 Visitas

En mi caso, las rutas llegan porque el router principal actúa como un switch para la VLAN3, y para el Amper es como si estuviera conectado directamente a la ONT.

 

Prefiero que sean si dinámicas, por si algún día Movistar decide cambiarlas, y el teléfono deja de funcionarme misteriosamente.

 

No te preocupes por lo del bridge, no lo necesito para nada.

Mensaje 8 de 19
3.017 Visitas

Buenas de nuevo @Theliel ,

 

Entonces, he probado como me has dicho, en modo Bridge, y luego en modo Router, ya que en Bridge no funcionaba. Ocurre lo de antes, se puede llamar y recibir, pero no hay tono ni voz desde ningún punto (emisor/receptor), viceversa.

 

Explico lo que he hecho por si he hecho algo mal.

 

En el Mitrastar:

1º Borrar todas las configuraciones WAN (la única manera que sé para borrarlo es cargarle la configuración por defecto del router pero borrando las entradas que había dentro del archivo de configuración romfile.cfg, dentro de las etiquetas <EtherWan> </EtherWan>)

2º Crear un perfil WAN, lo he puesto en modo Router (como ya dije en Bridge no me funcionaba), direccionamiento automático y SIN NAT.

3º Cambio la IP del aparato a 192.168.1.2, máscara 255.255.255.0 y dejo desactivado el DHCP.

4º Desactivo Firewall, Wireless, etc.

5º Accedo al apartado SIP > SIP Service Provider, y edito el primer perfil que por defecto es el que está activado. Selecciono el perfil WAN que he creado (VoIP).

6º Reinicio Mitrastar.

7º Conecto WAN del Mitra a puerto LAN del Asus.

 

¿Algo que deba cambiar o se me haya pasado cambiar en algún sitio para que ya funcione bien la voz?

Mensaje 9 de 19
2.970 Visitas

Buenas de nuevo @Theliel 

 

Entonces, he probado como me has dicho, en modo Bridge, y luego en modo Router, ya que en Bridge no funcionaba. Ocurre lo de antes, se puede llamar y recibir, pero no hay tono ni voz desde ningún punto (emisor/receptor), viceversa.

 

Explico lo que he hecho por si he hecho algo mal.

 

En el Mitrastar:

1º Borrar todas las configuraciones WAN (la única manera que sé para borrarlo es cargarle la configuración por defecto del router pero borrando las entradas que había dentro del archivo de configuración romfile.cfg, dentro de las etiquetas <EtherWan> </EtherWan>) 

2º Crear un perfil WAN, lo he puesto en modo Router (como ya dije en Bridge no me funcionaba), direccionamiento automático y SIN NAT.

3º Cambio la IP del aparato a 192.168.1.2, máscara 255.255.255.0 y dejo desactivado el DHCP.

4º Desactivo Firewall, Wireless, etc.

5º Accedo al apartado SIP > SIP Service Provider, y edito el primer perfil que por defecto es el que está activado. Selecciono el perfil WAN que he creado (VoIP).

6º Reinicio Mitrastar.

7º Conecto WAN del Mitra a puerto LAN del Asus.

 

Como digo, puedo llamar y recibir pero no se escucha la voz. ¿Algo que deba cambiar o se me haya pasado cambiar en algún sitio para que ya funcione bien la voz?

Mensaje 10 de 19
2.998 Visitas

Bueno pues por ahora parece que nada, no funciona.

Mensaje 11 de 19
2.963 Visitas

Buenos días @fodoto

 

Te informamos que desde la comunidad no damos soporte a ese tipo de configuración. No obstante dejamos el hilo abierto para que otros usuarios te puedan facilitar la información necesaria para solucionar tu consulta.

 

Un saludo.

 

Nacho.



Si necesitas soporte técnico en averías de Móvil, Fijo, Movistar+ o Internet Fijo (cobre o fibra), puedes acceder a nuestro apartado de Soporte Técnico o rellenar este formulario. También puedes contactar con nosotros llamando al 1002.

 Si necesitas contratar Fibra Ópticacomprobar tu cobertura Adsl y Fibrao ver información sobre la instalación de la fibra visita nuestra página ADSL y Fibra en movistar.es 

Solución aceptada.png
Mensaje 12 de 19
2.932 Visitas

Buenas @Theliel , no sé leíste mi respuesta. Todavía no he conseguido hacer funcionar el router como ATA.

 

Mensaje 13 de 19
2.891 Visitas

Buenas @fodoto 

 

Has probado a habilitar/deshabilitar ALG SIP? Otra opción... no recuerdo si el cliente SIP del Mitra lo permite, pero si te deja, prueba estableciendo un servidor STUN.

 

Si todo falla, quedaría capturar el tráfico SIP para para ver que es lo que falla. Si se puede llamar y recibir llamadas, y el problema está en que no se escucha, muy posiblemente sea un problema de NATeo, de ahí lo ideal de usar un bridge real.



Por privado solo asuntos privados, para lo demás la comunidad."El conocimiento nace del desacuerdo"
Mensaje 14 de 19
2.883 Visitas

Tal y como apunta @Theliel , el protocolo SIP es bastante sensible al NAT; es posible que Movistar haya realizado alguna configuración en sus servidores, y por eso haya dejado de funcionar esta configuración. Después de estar devanándome los sesos intentando hacer que funcionara, comparto la configuración que sí me está funcionando, por si le sirve a alguien más.

 

Equipos

  • ONT: HG8240
  • Router neutro: Linksys WRT3200ACM con OpenWrt 19.07.4
  • Router Movistar: Amper EG-663

 

Configuración

  • ONT
    • de fábrica
  • Router neutro
    • Conectado por WAN al puerto LAN1 del ONT
    •  VLAN1
      • tagged en CPU, LAN1
      • untagged en LAN2, LAN3, LAN4
      • off en resto
    • VLAN3
      • tagged en WAN, LAN1
      • off en resto
    • VLAN6
      • tagged en CPU, WAN
      • off en resto
    • WAN
      • Configuración típica de cualquier router neutro
      • Cliente de pppoe sobre VLAN6
    • LAN
      • Configuración típica de cualquier red local
      • IP estática + servidor DHCP
    • VoIP
      • En principio, no es necesario configurar ninguna red para VoIP
  • Router Movistar
    • Conectado por WAN al puerto LAN1 del router neutro
    • LAN
      • Configuración típica de cualquier red local
      • IP estática + servidor DHCP
      • No debe usarse la misma red que para la LAN del router neutro
    •  WAN
      • Cliente DHCP
    • VoIP
      • Cliente DHCP
      • Habilitar la recepción de rutas

Es decir, en el router neutro únicamente definimos una red WAN, que nos dará acceso a internet, y no es necesario definir una red para VoIP. Lo que sí hacemos es puentear la VLAN3 a uno de los puertos LAN; también colocamos en ese puerto la VLAN1, para que el router de Movistar pueda tener conexión a internet.

 

En el router de Movistar configuramos la red WAN como cliente de DHCP sobre VLAN1, y dejamos la red VoIP tal y como viene de fábrica (cliente DHCP sobre VLAN3). De esta manera, el router de Movistar se conecta a la red VoIP a través de la VLAN3, exactamente igual que si estuviera conectado a la ONT.

 

En el router neutro se puede añadir el puerto CPU a la VLAN3, y definir una red VoIP como cliente DHCP sobre VLAN3 (con la recepción de rutas habilitada); por ejemplo si queremos poner ahí un cliente SIP como Asterisk.

 

En teoría, el router de Movistar se podría poner en modo bridge, de forma que su red wifi y sus puertos ethernet estuvieran puenteados en la red LAN del router neutro, y así podríamos usar este router para ampliar la cobertura del router neutro; pero esta configuración no la he probado.

Mensaje 15 de 19
2.856 Visitas

Hola @fodoto.

 

Te pedimos disculpas por las molestias ocasionadas. ¿Podrías confirmarnos si con la información facilitada por @Theliel (muchas gracias por tu aportación) se ha resuelto tu consulta, por favor? Esperamos tu respuesta. 

 

Un saludo.

 

Angela. 



Si necesitas soporte técnico en averías de Móvil, Fijo, Movistar+ o Internet Fijo (cobre o fibra), puedes acceder a nuestro apartado de Soporte Técnico o rellenar este formulario. También puedes contactar con nosotros llamando al 1002.

 Si necesitas contratar Fibra Ópticacomprobar tu cobertura Adsl y Fibrao ver información sobre la instalación de la fibra visita nuestra página ADSL y Fibra en movistar.es 

Solución aceptada.png
Mensaje 16 de 19
2.714 Visitas

Hola @fodoto

 

Esperamos que con la información que te han indicado, hayas podido resolver la consulta ya que no hemos vuelto a recibir más notificaciones por tu parte. 

 

No obstante, solo tienes que respondernos con un nuevo mensaje si quieres que retomemos la consulta ya que dejaremos el hilo abierto. 

 

Un saludo

 

Griselda. 



Si necesitas soporte técnico en averías de Móvil, Fijo, Movistar+ o Internet Fijo (cobre o fibra), puedes acceder a nuestro apartado de Soporte Técnico o rellenar este formulario. También puedes contactar con nosotros llamando al 1002.

 Si necesitas contratar Fibra Ópticacomprobar tu cobertura Adsl y Fibrao ver información sobre la instalación de la fibra visita nuestra página ADSL y Fibra en movistar.es 

Solución aceptada.png
Mensaje 17 de 19
2.652 Visitas

Buenos días,

 

Siento la demora en la respuesta. He probado casi todas las últimas propuestas que me habéis mencionado tanto @Theliel como @eduperez , sin embargo, sigue sin funcionar, como dije: puedo llamar y recibir en ambos sentidos, pero no hay tono de llamada ni se escucha en ambos teléfonos.

 

La opción de capturar paquetes la he intentado pero con sinceridad, no sé lo que estoy buscando realmente.

 

Me doy por vencido. Creo que la mejor opción sería comprar un ATA, como el Grandstream HT801 y olvidarme del router de telefónica.

 

Un saludo y gracias igualmente.

Mensaje 18 de 19
2.399 Visitas

Hola @fodoto

 

Lamentamos que no te haya servido de ayuda a lo que estás buscando y sentimos la decisión que has tomado en cuanto al Router. No obstante, mantenemos el hilo abierto por si se quiere retomar el caso con nueva información. 

 

Y si más adelante, tienes cualquier otra consulta, ya sabes donde encontrarnos. Agradecer nuevamente a @Theliel y @eduperez por los aportes y colaboración. 

 

Un saludo. Mª Jesús.



Si necesitas soporte técnico en averías de Móvil, Fijo, Movistar+ o Internet Fijo (cobre o fibra), puedes acceder a nuestro apartado de Soporte Técnico o rellenar este formulario. También puedes contactar con nosotros llamando al 1002.

 Si necesitas contratar Fibra Ópticacomprobar tu cobertura Adsl y Fibrao ver información sobre la instalación de la fibra visita nuestra página ADSL y Fibra en movistar.es 

Solución aceptada.png
Mensaje 19 de 19
2.329 Visitas