Problema Asterisk y host telefonica.net

Highlighted
Problema Asterisk y host telefonica.net

Buenas tardes,

Desde hace casi dos años tenía configurada una centralita con Asterisk y funcionando correctamente. Pero desde ayer que no consigo realizar llamadas, no consigo conectar con telefonica.net.

 

He reseteado el router y nada, sigo igual. ¿Es posible que se haya realizado algún cambio?

 

Estos son los datos que tengo:

 

[MovistarOut]
type=peer
fromuser=xxx
secret=xxx
host=telefonica.net
fromdomain=telefonica.net
outboundproxy=10.31.255.134:5070
nat=yes
insecure=port,invite
dtmfmode=auto
disallow=all
allow=ulaw,alaw

 

Saludos!

Mensaje 1 de 27
3.886 Visitas
26 RESPUESTAS 26
Highlighted
Re: Problema Asterisk y host telefonica.net

Buenoc dias @njoy, te informamos que desde la comunidad no nos es posible dar soporte a dispositivos no facilitados por Movistar, no obstante dejo abierto el hilo por si algún forero puede ayudarte. Te paso este hilo por si puede servirte de ayuda:

 

https://comunidad.movistar.es/t5/Soporte-T%C3%A9cnico-de-Fibra-%C3%93ptica/VoIP-Movistar-y-Asterisk/...

 

https://comunidad.movistar.es/t5/Soporte-T%C3%A9cnico-de-Fibra-%C3%93ptica/Asterisk-con-FTTH/td-p/25...

 

Saludos.



Si necesitas soporte técnico en averías de Móvil, Fijo, Movistar+ o Internet Fijo (cobre o fibra), puedes acceder a nuestro apartado de Soporte Técnico o rellenar este formulario. También puedes contactar con nosotros llamando al 1002.

 Si necesitas contratar Fibra Ópticacomprobar tu cobertura Adsl y Fibrao ver información sobre la instalación de la fibra visita nuestra página ADSL y Fibra en movistar.es 

Solución aceptada.png
Mensaje 2 de 27
3.874 Visitas
Re: Problema Asterisk y host telefonica.net

Buenas,

 

Prueba a poner esta línea en tu archivo /etc/hosts:

 

10.31.255.134     telefonica.net

 

un saludo.

Mensaje 3 de 27
3.869 Visitas
Highlighted
Re: Problema Asterisk y host telefonica.net

Hola, yo estoy igual. He probado en mi centralita Asterisk en una Raspberry y desde ayer por la noche no funciona ni resuelve a telefonica.net, por lo cual el servicio VoIP nos lo han [....]o.

He probado desde otro ordenador con otra centralita (una linksys) de un amigo y esta exactamente igual.

¿Que demonios para con el dominio de telefonica.net?

No funciona ni con los softphones tipo PhonerLite y similares.

¿Cuando va a estar activo el servicio? Tengo un contrato Fusion Pro 300MB y para mi que eso funcione es vital (soy autónomo y no recibo llamadas).

P.D.: En otros apartados de los foros se ve que usuarios con la dirección de correo telefonica.net también les ha fallado.

Mensaje 4 de 27
3.839 Visitas
Highlighted
Re: Problema Asterisk y host telefonica.net

Pues muchas gracias!!!!

Llevo desde ayer con el tema, Emoticono triste

En mi caso se ha resuelto y ya puedo realizar llamadas desde el servidor Asterisk añadiendo la linea :

10.31.255.134     telefonica.net

al archivo /etc/hosts

 

Gracias de nuevo 😉

 

Mensaje 5 de 27
3.819 Visitas
Highlighted
Re: Problema Asterisk y host telefonica.net

Muchas gracias @Gran PC

Con esa línea en el archivo hosts mi centralita vuelve a funcionar de nuevo correctamente.

A ver si Movistar espabila y arregla la dirección "telefonica.net", que llevan una racha de mosqueos entre subida de precios y falsas subidas de megas en los móviles a los que tenemos tarifas descatalogadas.

Saludos.

Mensaje 6 de 27
3.781 Visitas
Highlighted
Re: Problema Asterisk y host telefonica.net

Buenos días,

 

Pues esta mañana, me he puesto a realizar pruebas para cerciorarme de que todo funcionaba bien, y... nada, con la solución de ayer podía llamar, pero ahora no recibo llamadas. Lo he solucionado cambiando (según indicó @Gran PC) la dirección IP de 10.31.255.134 a 213.4.130.95 en el archivo  /etc/hosts, que es la que corresponde al dominio telefonica.net.

 

213.4.130.95    telefonica.net

 

De este modo funciona perfectamente.

Gracias @Gran PC!

 

Saludos!

Mensaje 7 de 27
3.751 Visitas
Highlighted
Re: Problema Asterisk y host telefonica.net

A mi me paso lo mismo y lo solucione de la misma forma, pero ya no me funciona la identificación de llamada.

Mensaje 8 de 27
3.706 Visitas
Highlighted
Re: Problema Asterisk y host telefonica.net

@ma.riveraYo tuve que poner esto en mi extensions.lua para que me funcionara el caller ID cuando configuré mi servidor inicialmente:

 

 

        local cid = channel.SIP_HEADER( "P-Asserted-Identity" ):get()
        if cid then
                cid = cid:match( "sip:(%+%d+)@?" )
                if cid then
                        channel.CALLERID( "num" ):set( cid )
                end
        end

 

También debería poderse hacer con el dialplan "normal" de Asterisk, pero no sabría decirte cómo.

Mensaje 9 de 27
3.704 Visitas
Highlighted
Re: Problema Asterisk y host telefonica.net

Hola.

Si, es verdad. En los terminales que tengo conectados a la centralita aparece "llamada anónima". Voy a probar con el código que has facilitado, a ver si funciona bien con mis teléfonos Linksys.

P.D.: Señores de Movistar. Seríais tan amables de quitar el mensaje de "problema resuelto" y dejar de nuevo el problema como pendiente de resolver? El problema sigue existiendo, el servicio no funciona del todo correctamente.

Mensaje 10 de 27
3.688 Visitas
Highlighted
Re: Problema Asterisk y host telefonica.net
Mensaje 11 de 27
3.678 Visitas
Highlighted
Re: Problema Asterisk y host telefonica.net

Es increíble, en el año que estamos y que te cobren por eso....

Es como si ahora, en una aplicación tipo "WhatsApp" empezasen a cobrar por saber quien nos escribe Emoticono muy feliz

parece que no pagamos suficiente. En fin...

Mensaje 12 de 27
3.656 Visitas
Highlighted
Re: Problema Asterisk y host telefonica.net

No, no tiene nada que ver con eso. Eso no es para fibra.

Mensaje 13 de 27
3.643 Visitas
Highlighted
Re: Problema Asterisk y host telefonica.net

Buenas compis

 

Tener cuidado con las asignaciones estáticas de IPs en hosts. La razón por la que os funciona a algunos y a otros no, es por errores que tenéis en la configuración de Asterisk, y como este interpreta por un lado el register y por otro el proxy.

 

Recuerdo hace algún tiempo un compañero que puso el tráfico capturado y se veía perfectmente lo que pasaba. El dominio a usar es siempre tanto para realm y domain como para otros es telefonica.net, pero realmente todas las conexiones se hacen a través del proxy, con lo que a pesar de que ahora mismo telefonica.net no se pueda resolver, es indiferente, porque no se requiere una IP para él, no se hacen conexiones a dicho host.

 

Es decir, sí, aunque telefonica.net se use internamente como "identificador", absolutamente todo el tráfico se realiza por el proxy. Si no se configura bien Asterisk, el tráfico en vez de enviarlo al proxy lo manda a telefonica.net, con lo que como es natural no funcionará bien de ningún modo. Esto es muy sencillo de verlo si se captura el tráfico.

 

Los que forzais la redirección de IP de telefonica.net, es un truco innecesario, lo que hay que decirle a asterisk es que use el proxy para registrar y "dialogar".

 

Asterisk si no lo configurais bien, toma telefonica.net para hacer los


Por privado solo asuntos privados, para lo demás la comunidad."El conocimiento nace del desacuerdo"
Mensaje 14 de 27
3.630 Visitas
Highlighted
Re: Problema Asterisk y host telefonica.net

Buenos días,

 

Pues he realizado unas pruebas, bajo mi poco conocimiento sobre Asterisk, etc... a ver si me podéis echar una mano con el tema para averiguar donde falla.

 

SIN modificar el mencionado archivo "hosts",

En el archivo sip.conf tengo la siguiente configuración de salida:

[MovistarOut]
type=peer
host=telefonica.net
fromuser=xxxxxxxxx
secret=xxxxxxxxx ; creo que no es necesario
fromdomain=telefonica.net
port=5070
outboundproxy=10.31.255.134:5070
nat=yes

Ahora con ngrep obtengo lo siguiente:

 

interface: any
filter: (ip or ip6) and ( port 5070 )
#
U +6.022840 192.168.1.33:5094 -> 10.31.255.134:5070
REGISTER sip:telefonica.net SIP/2.0
Via: SIP/2.0/UDP 192.168.1.33:5094;branch=z9hG4bK3cc159c5;rport
Max-Forwards: 70
From: <sip:xxxxxxxxx@telefonica.net>;tag=as0f37764b
To: <sip:xxxxxxxxx@telefonica.net>
Call-ID: 351572564bd67310089251bd185ee472@192.168.1.33
CSeq: 102 REGISTER
Supported: replaces, timer
User-Agent: Asterisk PBX
Expires: 120
Contact: <sip:s@192.168.1.33:5094>
Content-Length: 0


#
U +0.007273 10.31.255.134:5070 -> 192.168.1.33:5094
SIP/2.0 200 OK
Via: SIP/2.0/UDP 192.168.1.33:5094;received=10.23.8.196;branch=z9hG4bK3cc159c5;rport=5094
From: <sip:xxxxxxxxx@telefonica.net>;tag=as0f37764b
To: <sip:xxxxxxxxx@telefonica.net>;tag=aprqb2eh5efc1jpo6-ck9tjf20000c6
Call-ID: 351572564bd67310089251bd185ee472@192.168.1.33
CSeq: 102 REGISTER
P-Associated-URI: <sip:xxxxxxxxx@telefonica.net>
P-Associated-URI: <tel:+34xxxxxxxxx>
P-Associated-URI: <sip:f2016004887025_1@telefonica.net>
Contact: <sip:s@192.168.1.33:5094>;expires=70
Service-Route: <sip:s@10.31.255.134:5070;transport=udp;lr>

Y en asterisk, con "sip show peers" obtengo esto:

CLI> sip show peers
Name/username             Host                                    Dyn Forcerport Comedia    ACL Port     Status      Description
User0                 192.168.1.42                             D  Yes        Yes            5094     Unmonitored
MovistarIn            10.31.255.134                               Yes        Yes            5060     Unmonitored
MovistarOut           (Unspecified)                               Yes        Yes            0        Unmonitored
User1                 192.168.1.42                             D  Yes        Yes            5094     Unmonitored
4 sip peers [Monitored: 0 online, 0 offline Unmonitored: 3 online, 1 offline]

sss*CLI> sip show registry Host dnsmgr Username Refresh State Reg.Time 10.31.255.134:5070 N xxxxxxxxx@te 55 Registered Fri, 20 Apr 2018 08:48:19

Con lo que no puedo realizar llamadas, pero si recibirlas.

A ver si me podéis echar un "cable".

Gracias!

Saludos!

 

 

Mensaje 15 de 27
3.600 Visitas
Highlighted
Re: Problema Asterisk y host telefonica.net

@njoy

 

En tu caso, veo dos posibles problemas, uno de ellos es más que una seguridad

 

En puerto tienes especificado 5070. 5070 es el puerto del servidor proxy, el puerto SIP es 5060. Por otro lado las conexiones que realiza el cliente usa el 5094, deberían de ser 5060


Por privado solo asuntos privados, para lo demás la comunidad."El conocimiento nace del desacuerdo"
Mensaje 16 de 27
3.550 Visitas
Highlighted
Re: Problema Asterisk y host telefonica.net

njoy, no especificas que problema tienes.

Sin modificar el hosts es posible que te funcione, ya que tengo centralitas instaladas en todas España  y de momento solo me están fallando las de Madrid y Ceuta.

Lo he puesto mas veces en este foro, pero te lo pongo de nuevo.

Configuración del sip trunk:

 TelefonicaOut

type=peer

host=telefonica.net

user=91XXXXXXX

username=91XXXXXXX

fromuser=91XXXXXXX

secret=91XXXXXXX

fromdomain=telefonica.net

outboundproxy=10.31.255.134:5070

port=5060

nat=force_rport,comedia

insecure=port,invite

dtmfmode=auto

disallow=all

allow=ulaw&alaw

context=from-pstn

qualify=no

trustpid=yes

 

TelefonicaIn

type=peer

host=10.31.255.134

user=91XXXXXXX

username=91XXXXXXX

fromuser=91XXXXXXX

secret=91XXXXXXX

fromdomain=telefonica.net

port=5060

nat=force_rport,comedia

insecure=port,invite

dtmfmode=auto

disallow=all

allow=ulaw&alaw

context=from-pstn

qualify=no

trustpid=yes

 

Registro

91XXXXXXX@telefonica.net:91XXXXXXX@10.31.255.134:5070/91XXXXXXX

Mensaje 17 de 27
3.527 Visitas
Highlighted
Re: Problema Asterisk y host telefonica.net

Buenas tardes,

 

Gracias por las repuestas.

@Theliel, he cambiado el port=5070 a port=5060, pero sigue sin funcionar.

En cuanto a lo del puerto 5094, tengo puesto en el archivo sip.conf, en la sección [general] la siguiente línea,

udpbindaddr=192.168.1.33:5094

corríjame si me equivoco, pero ese puerto solo se utiliza para las conexiones entre clientes SIP y el servidor Asterisk. de todos modos lo he cambiado al 5060 y sigo sin poder realizar llamadas.

 

@ma.rivera,

El problema que tengo es que, desde hace unos días no puedo realizar llamadas sin tener la línea

 

213.4.130.95    telefonica.net

en  mi archivo /etc/hosts. He estado sin problemas durante cerca de 2 años con las configuraciones actuales, pero desde hace un par de días no puedo realizar llamadas sin la modificación mencionada. No se ha tocado nada del servidor, ni se ha actualizado absolutamente nada.

 

He probado con la configuración que ha escrito, pero el trunk "MovistarOut" no lo registra,

 

CLI> sip show peers
Name/username             Host                                    Dyn Forcerport Comedia    ACL Port     Status      Description
User0                 192.168.1.42                             D  Yes        Yes            5060     Unmonitored
MovistarIn            10.31.255.134                               Yes        Yes            5060     Unmonitored
MovistarOut           (Unspecified)                               Yes        Yes            0        Unmonitored
User1                 192.168.1.42                             D  Yes        Yes            5060     Unmonitored
4 sip peers [Monitored: 0 online, 0 offline Unmonitored: 3 online, 1 offline]


sss*CLI> sip show registry
Host                                    dnsmgr Username       Refresh State                Reg.Time
10.31.255.134:5070                      N      xxxxxxxxx@te        55 Registered   

No sé... que raro!

 

Gracias de todos modos 😉

Saludos!

 

 

Mensaje 18 de 27
3.511 Visitas
Highlighted
Re: Problema Asterisk y host telefonica.net

Desde hace unos días, yo lo note este pasado lunes, el dominio telefonica.net no esta publicado en ningún DNS, es decir que si buscas telefonica.net en un DNS, este no sabe en que IP se encuentra. ¿Por que? pues eso lo sabrá telefónica.  

Por ese motivo, hay que decirle a linux que no busque telefonica.net en los DNS sino que al modificar /etc/hosts ya le estas diciendo en que IP esta telefonica.net.

Hasta aquí normal, Pero al con la configuración del troncal que tenia funcionando perfectamente, al modificar el fichero hosts deje de recibir llamadas por que tuve que cambiar la configuración por la que te he indicado.

Y aún así, no funciona la identificación de llamada debido al INVITE incorrecto que envía telefónica.

Mensaje 19 de 27
3.502 Visitas
Highlighted
Re: Problema Asterisk y host telefonica.net

Alguien ha podido solucionar el tema del Unknown ID en las llamadas entrantes?

 

Gracias !

Mensaje 20 de 27
3.425 Visitas
Highlighted
Re: Problema Asterisk y host telefonica.net

Si, tiene solución.

Nuestra maravillosa telefónica, ha desactivado el servicio de identificación de llamadas. Por lo que tienes que contratarlo a parte pagando 2 € mas. 

Bueno, hasta ahora iban de 5 en 5 euros, ahora solo son 2.

Hasta los mismos estoy.

Mensaje 21 de 27
3.417 Visitas
Highlighted
Re: Problema Asterisk y host telefonica.net

Mágicamente ya me funciona lo del identificador de las llamadas 🙂

 

Aún así, esta mañana he tenido problemas con las llamadas salientes... la solución ha sido dejar el archivo /etc/hosts como estaba anteriormente, sin la declaración del dominio telefonica.net pero poner como DNS los servidores de movistar

80.58.61.250 80.58.61.254 en FreePBX... automáticamente me ha empezado todo a funcionar... me jode porque soy cliente y partner de Cisco Umbrella pero bueno, por un equipo que no tenga protegido con Umbrella tampoco es tan grave...

 

Muchas gracias!

Mensaje 22 de 27
3.374 Visitas
Highlighted
Re: Problema Asterisk y host telefonica.net

Nada... al hacer un SIP RELOAD me ha perdido el peer de llamadas entrantes... he tenido que volver a meter telefonica.net en el /etc/hosts y hacer un sip reload...

 

Pero bueno acutalmente recibo y hago llamadas y, además, me aparece el número de quien me llama.

 

Gracias!

Mensaje 23 de 27
3.372 Visitas
Highlighted
Re: Problema Asterisk y host telefonica.net

A mí me pasa exactamente igual. Con la raspbx imposible desde hace unos dias, cuando hago nslookup telefonica.net desde terminal linux, dice que no existe el nombre. Repasando los logs de Asterisk, da error precisamente de eso"Unable to lookup 'telefonica.net' etc etc.

Mosqueado, he cargado FreePBX en un servidor HP Proliant y EXACTAMANTE IGUAL. He posteado en el FeePBX forum, pero hasta ahora nada...

Curiosamente, si conecto el adaptador GrandStream HT802 (el que usaba para terminales) apuntando a los settings de telefoncia, funciona, pero no a traves de freepbx. Igual con softphones de PC, tipo Phonerlite, todo correcto.

Realmente estoy desesperado, puest tengo 6 extensiones muertas de risa..

Gracias a todos y saludos

Miguel.

Mensaje 24 de 27
3.344 Visitas
Highlighted
Re: Problema Asterisk y host telefonica.net

Pues yo lo tengo funcionando, simplemente con la configuración del troncal como he explicado antes y modificando el fichero /etc/hosts, el único problema es que al estar telefónica quitando el servicio gratuito de identificador de llamada, no se que hace que unas veces aparece como desconocido y otras como 000000000. Pero las llamadas funcionan bien. 

Mensaje 25 de 27
3.340 Visitas