Soluciones Fallos Mitrastar (Batería, WIFI, DHCP...)

Re: Soluciones Fallos Mitrastar (Batería, DHCP...)
Alguna manera tiene que haber para activar el doblé canal, a no ser qué sea los driver.
Mensaje 76 de 991
1.960 Visitas
Re: Soluciones Fallos Mitrastar (Batería, DHCP...)

Algún problema con el seteo de la interfaz WIFI al iniciar entonces, a lo mejor la nvram esta bien, pero los scripts/demonios y otros que la configuran no lo hacen bien. Aquí creo q era iwpriv. Si se puede setear a mano de algún modo, imagino que se podrá buscar un fix

 

El driver puede estar mal, pero el echo de que funcione si se configura en 40Mhz desde los 20MHz es que al menos funcionar funciona aunque séa solo en un escenario concreto, con lo que es muy posible que se pueda hacer algo


Por privado solo asuntos privados, para lo demás la comunidad."El conocimiento nace del desacuerdo"
Mensaje 77 de 991
1.960 Visitas
Re: Soluciones Fallos Mitrastar (Batería, DHCP...)

haber si hay suerte y es facil la solucion, asi tenemos el doble canal

Mensaje 78 de 991
1.919 Visitas
Re: Soluciones Fallos Mitrastar (Batería, DHCP...)

Pues definitivamente es un problema del Driver el problema del WIFI

 

En función de la configuración en la que se establezca HT_BW (0 banda de 20MHz, 1 Banda de 20/40Mhz), el router levanta la interfaz con un "driver" diferente. En realidad es el mismo Driver pero aplica diferentes configuraciones de este dependiendo del adaptador WIFI que el cree que hay. La firmware soporta diferentes adaptadores, presupongo que es porque Mitrastar tiene placas muy similares. El caso es que si HT_BW está a 0 levanta la interfaz de un modo en el que es posible configurarla a posteriori para poder usar la banda de 20/40. En cambio si se levanta la interfaz estando HT_BW 1, el Driver impide por algún error que la banda pueda configurarse en 20/40 bajo ninguna circunstancia, la única forma de poder revertir esto es bajar la interfaz y volver a subirla estando HT_BW configurado a 0.

 

El Router levanta la interfaz al inicio de arrancarse, con lo que cuando en la interfaz web se configura HT_BW a 1 (20/40), y se aplican los cambios, estos FUNCIONAN perfectamente SOLO si el Router había arrancado estando HT_BW a 0. Si reiniciamos estando HT_BW a 1, se levantarán mal la interfaz, y ya da igual que se ponga HT_BW a 0 y luego a 1, porque hasta que no se levante la interfaz bien (que lo hace el router solo al iniciarse) no hay nada que hacer

 

Resumiendo:

 

-Es posible usar 20/40 sólo si el Router arranca con HT_BW a 0 y posteriromente se configura a 1.

-Si el Router arranca en 20/40, l aúnica forma de poder usar la banda de 20/40 es bajando la interfaz, configurando HT_BW a 0, volviendo a levantar la Interfaz y volviendo a configurar BT_BW a 1.

 

Es posible un "fix"? Todo se puede hacer por Shell sin reiniciar, automatizarlo es más complicado porque hasta que la interfaz no se levante no se peude configurar. La solución sería dejar siempre BT_BW a 0, y automatizarlo de algún modo para establecerlo a 1, pero como digo es más complicado porque hay que dar tiempo a que la interfaz se levante. Luego si tengo otro ratito pruebo un par de cosas más


Por privado solo asuntos privados, para lo demás la comunidad."El conocimiento nace del desacuerdo"
Mensaje 79 de 991
1.885 Visitas
Re: Soluciones Fallos Mitrastar (Batería, DHCP...)

uuuuf esta complicado entonces, haber si consigues algo

Mensaje 80 de 991
1.882 Visitas
Re: Soluciones Fallos Mitrastar (Batería, DHCP...)

Excelente tarea de investigación @Theliel. Visto este hilo, yo no sé cómo a Movistar no se le cae la cara de vergüenza por la calidad de routers que monta. Que un usuario tenga que llegar a estos extremos es lamentable. Este ahora mismo es el único que montan para fibra con TV y es una auténtica pena. Pero es que los que han estado montando años atrás son incluso peor (Amper EG 663, Comtrend VG 8050, Comtrend 5813, etc). Que lo hagan otras compañías lo podría entender, pero es que Movistar tiene practicamente el monopolio en España, es líder indiscutible. Y no sólo eso, es que su competencia (a años luz de presupuesto, clientes y ganancias) montan routers muchísimo mejores que esto...  Sólo espero que alguien de las altas esferas lea esto y reaccione de una maldita vez.

Mensaje 81 de 991
1.878 Visitas
Re: Soluciones Fallos Mitrastar (Batería, DHCP...)

Hola,

 

 tras añadir las lineas al archivo cfg para tratar de solucionar el problema del consumo de las baterias por Wifi, en mi caso, 3 moviles y una tablet, no noto la mejoria que comentan otros compañeros, me da la sensación que he pasado de un 15% a la hora, como estaba antes, a un 10% de consumo, lejos, muy lejos del 2% por 3G.Mejor pero todavia muy alto en comparacion con otros Wifi y con el 3G.

 

Compruebo el valor de mcast_solicit y sigue en 0, pero nada

# cat /proc/sys/net/ipv4/neigh/br0/mcast_solicit
0

 

Gracias Theliel y a los que te estan echando una mano por el curro

 

Creo que insistiré con las reclamaciones.

 

Un saludo

Mensaje 82 de 991
1.850 Visitas
Re: Soluciones Fallos Mitrastar (Batería, DHCP...)

He realizado mas comprobaciones, y sin duda se ha notado mejoria, pero por ejemplo en casa d emi novia en segundo lugar está dispositivo inactivo y en cambio en casa tengo sitema operativo de android...

 

Creo que gasta mucho menos pero aun gasta

Mensaje 83 de 991
1.832 Visitas
Re: Soluciones Fallos Mitrastar (Batería, DHCP...)

@Toni_78estás en la B21?? La B14 tiene otro problema totalmente diferente, este "fix" va pensado para la B21. En lo personal no he detectado ningún otro fallo en lo referente a la sangría con la batería. El único tráfico adional que pudiese hipotéticamente afectar (pero de un modo infinitamente menor) es IPv6, que lo puedes deshabilitar desde la interfaz Web. Lo único que quedaría a parte de ello sería habilitar la gestión de energía de las extensiones WIFI, que creo recordar que por defecto está deshabilitado... puedo intentar añadirlo también a ver como interactúa todo junto

 

@zadkyn, ya tengo un "fix" para el Wifi, mañana lo probaré mejor. Funcionar funciona, pero tengo que decir que el WIFI del router es más inestable, no por fallo del fix, sino por el Driver del Router. Por suerte la interzaz se levanta antes de la ejecución de nuestro bloque, con lo que se puede "insertar". Mañana hago más pruebas y mediciones a ver si la banda de 40Mhz puede llegar a ser usable, le pediremos a @taker59 que lo pruebe también en un entorno real por si nos volvemos a cargar su router (pobrecillo, es un conejillo de indias).

 

@David B me remito a lo que he comentado a Toni


Por privado solo asuntos privados, para lo demás la comunidad."El conocimiento nace del desacuerdo"
Mensaje 84 de 991
1.830 Visitas
Re: Soluciones Fallos Mitrastar (Batería, DHCP...)
Gracias y tranquilo solo te estaba informando ahirs misno estoy muu contento con el gasto contando que sntes hacia dos horas de pantalla!
Mensaje 85 de 991
1.827 Visitas
Re: Soluciones Fallos Mitrastar (Batería, DHCP...)

que bien ojala que funcione, esperando con ganas estoy!!   @Theliel      este router es una [....], en mi caso tengo como un relay entre el portatil y el wifi, como que tarda en racionar, cuando entro en una pagina web se queda el navegador en esperando repuesta como 30 segunod o mas, y asi me pasa con todas las paginas, y pasa una vez no y dos veces si

Mensaje 86 de 991
1.800 Visitas
Re: Soluciones Fallos Mitrastar (Batería, DHCP...)

Bueno, antes de ponerlo en el primer post, para ver si alguien quiere probarlo en un entorno real, en mis pruebas funciona "bien", aunque no lo he podido probar demasiado. Teniendo en cuenta los problemas que ha tenido ya Taker no me gustaría que alguien bloquease el suyo... que no todos tenéis cables para desbloquearlo:

 

Activar al inicio la banda de 40MHz (Puede causar más inestabilidad en el WIFI del router). En Channel poner el canal que use cada uno, 0 para automático. Es necesario especificarlo, y si se modifica en la interfaz web se debe de modificar aquí también (para que no haya problemas con el canal secundario)

 

wifi_fix="/userfs/bin/iwpriv ra0 set HtBw=1; /userfs/bin/iwpriv ra0 set Channel=13"

 

Por otro lado, para activar otra función que por defecto viene apagada y que afecta a la batería de móviles tables y otros. En este caso debe de ir en la sección <WLan> y dentro de WLan en Entry0, se puede poner después de por ejemplo la última entrada, despúes de RADIUS_Server

 

APSDCapable="1"

 

Este último lo he probado y efectivamente los dispositivos entran en power save mode cuando estan unos segundos a pantalla apagada, lo que ayuda aun más en reducir el consumo por wifi. Posiblemente cuando lo pase al post principal, para evitar tener que cambiar en muchos sitios lo pondré en la misma sección que el resto, pero por ahora es necesario ponerlo en WLAN Entry


Por privado solo asuntos privados, para lo demás la comunidad."El conocimiento nace del desacuerdo"
Mensaje 87 de 991
1.779 Visitas
Re: Soluciones Fallos Mitrastar (Batería, DHCP...)

Gracias @Theliel ,voy a probarlo corriendo jejeje.

 

P.d:Si no respondo en unos pocos minutos ................ es que se ha brickeao jejeje .

Mensaje 88 de 991
1.771 Visitas
Re: Soluciones Fallos Mitrastar (Batería, DHCP...)

taker59 escribió:

Gracias @Theliel ,voy a probarlo corriendo jejeje.

 

P.d:Si no respondo en unos pocos minutos ................ es que se ha brickeao jejeje .


Funciona de lujo los 40Mhz.,ahora va perfecto.Ademas se puede cambiar de 20 a 40 y viceversa sin peligro.

Mensaje 89 de 991
1.761 Visitas
Re: Soluciones Fallos Mitrastar (Batería, DHCP...)
No, no puedes alternar desde la interfaz, si en la interfaz lo pones en auto, al reiniciar no funcionará

Por privado solo asuntos privados, para lo demás la comunidad."El conocimiento nace del desacuerdo"
Mensaje 90 de 991
1.762 Visitas
Re: Soluciones Fallos Mitrastar (Batería, DHCP...)

Otra cosa muy importante y es que para que funcione correctamente el fix de los 40Mhz,en el apartado de <WLan> <Common APOn="1" ................... teneis que poner en HT_BW=  dejarlo en "0" .Si esta puesto en "1" estara activado en 40mhz pero el fix no funcionara de ninguna manera.Si lo dejais en "0" funcionara aunque en la gui del router salga que esta a 20Mhz.Si quereis que funcione a 20Mhz (un solo canal) solo teneis que ponerlo en 40 y volverlo a poner 20 y aplicais.Si quereis otra vez 40,poner en auto y ya estara de nuevo el doble canal sin necesidad de apagar el wifi.

Mensaje 91 de 991
1.756 Visitas
Re: Soluciones Fallos Mitrastar (Batería, DHCP...)

Gracias, voy a probar por que he tenido que empezar a usar un hg56a con openwrt  de lo mal que me va el mirastra, voy a probar lo del wifi a 40hz

Mensaje 92 de 991
1.757 Visitas
Re: Soluciones Fallos Mitrastar (Batería, DHCP...)

Si que se puede alternar ,solo se tiene que poner a "0" en  HT_BW=  .

Mensaje 93 de 991
1.756 Visitas
Re: Soluciones Fallos Mitrastar (Batería, DHCP...)

0 se pone en la linea que añadimos en el config o en el apartado que esta ya en el archivo config?

Mensaje 94 de 991
1.748 Visitas
Re: Soluciones Fallos Mitrastar (Batería, DHCP...)

En el autoexec NO,se tiene que editar en el apartado que de la WLAN.

Mensaje 95 de 991
1.745 Visitas
Re: Soluciones Fallos Mitrastar (Batería, DHCP...)

He realizado unas cuantas pruebas y lo mejor es como lo he puesto.Ademas de poner en el autoexec el fix de @Theliel  de los 40Mhz,se tiene que modificar en el apartado WLAN la opcion HT_BW= y dejarlo en "0". De esta forma aunque se reinicie el router ,siempre arrancara con el doble canal activado y trabajando a 300 aunque salga en el status del router que esta a 150.

 

P.d:Eso si,no toqueis en la opcion del rouer el Channel Width : ,dejarlo como esta a 20Mhz.Si lo tocais y luego reiniciais no se pondra ya en los 40Mhz.

Mensaje 96 de 991
1.724 Visitas
Re: Soluciones Fallos Mitrastar (Batería, DHCP...)

he echo todas las pruebas y aunque tengo 40 mhz la conexion por wifi me sigue fallando, el wifi es malisimo, he tenido que volver a conectar mi viejo router hg556a con openwrt y va perfecto, el telefono lo tengo por el ont y la fibra con tv y demas por el hg556a con openwrt, existe alguna posibilidad de instalar en mirastra openwrt? o alguna manera de liberar un livebox next  que tiene banda 5ghz wifi AC ? yo puedo ofrecerme a hacer pruebas. Yo creo que en mi caso el wifi en mirastra me va mal por que tengo muchas cosas conectada por wfi, tengo 2 impresoras wifi, un android tv, un portatil y 4 moviles android

Mensaje 97 de 991
1.706 Visitas
Re: Soluciones Fallos Mitrastar (Batería, DHCP...)

zadkyn escribió:

que bien ojala que funcione, esperando con ganas estoy!!   @Theliel      este router es una [....], en mi caso tengo como un relay entre el portatil y el wifi, como que tarda en racionar, cuando entro en una pagina web se queda el navegador en esperando repuesta como 30 segunod o mas, y asi me pasa con todas las paginas, y pasa una vez no y dos veces si


Me pasa lo mismo con el portatil,tanto con windows como con linux..es un Acer ?
 

Mensaje 98 de 991
1.656 Visitas
Re: Soluciones Fallos Mitrastar (Batería, DHCP...)

A ver, que nos liamos todos.

 

El fix funciona SOLO cuando en la interfaz web aparece 20MHz. No pasa nada por ponerse en Auto, pero al reiniciar no funcionará, y sólo volverá a funcionar si se pone en 20 y se reinicia.

 

No es necesario editar el archivo y poner HT_BW=0, porque precisamente ese parámetro es el que modifica las opciones de WIFI... es decir, que si en la interfaz web estamos poniendo 20Mhz, realmente lo que estamos haciendo es lo mismo que poner en el archivo de configuración HT_BW=0, con lo que no es necesario.

 

Lo único que hay que aplicar es que para que funcione, la interfaz web tiene que estar en 20Mhz, mientras esté así, funciona. Si se pone en Auto funcionará hasta que se reinicie.

 

@zadkyn el fix arregla la imposibilidad de usar los 40Mhz (lo que duplica la velocidad teorica del wifi), pero el adaptador es el que es, es decir... q peras al olmo poco... jajaja. Sí es verdad que cuando esta trabajando en 40Mhz si he visto que a veces, el driver falla, lanza un error y desconecta al cliente, y hay que esperar unos seg a que vuelva a conectar.

 

Sobre instalar OpenWRT... lo dudo. Posible siempre es posible crear una firmware totalmente nueva y bla bla bla... pero vamos, nadie va a hacerlo. Y sobre el Livebox... a lo mejor es posible, no lo sé, pero tendría que asistirte cualquier otro, no puedo "entretenerme" con nada que no tenga. No la tengo tomada con el Mitrastar... es que es el que Movistar me puso, así que es con el que trateo (ni siquiera uso el router en mi línea, uso mi propio Router)

 

Por otro lado, probar el añadido de la batería a ver si los más atentos al consumo ven una mejoría. Paso los dos al primer post de todos modos


Por privado solo asuntos privados, para lo demás la comunidad."El conocimiento nace del desacuerdo"
Mensaje 99 de 991
1.656 Visitas
Re: Soluciones Fallos Mitrastar (Batería, DHCP...)

Theliel escribió:

@Toni_78estás en la B21?? La B14 tiene otro problema totalmente diferente, este "fix" va pensado para la B21. En lo personal no he detectado ningún otro fallo en lo referente a la sangría con la batería. El único tráfico adional que pudiese hipotéticamente afectar (pero de un modo infinitamente menor) es IPv6, que lo puedes deshabilitar desde la interfaz Web. Lo único que quedaría a parte de ello sería habilitar la gestión de energía de las extensiones WIFI, que creo recordar que por defecto está deshabilitado... puedo intentar añadirlo también a ver como interactúa todo junto

 

@zadkyn, ya tengo un "fix" para el Wifi, mañana lo probaré mejor. Funcionar funciona, pero tengo que decir que el WIFI del router es más inestable, no por fallo del fix, sino por el Driver del Router. Por suerte la interzaz se levanta antes de la ejecución de nuestro bloque, con lo que se puede "insertar". Mañana hago más pruebas y mediciones a ver si la banda de 40Mhz puede llegar a ser usable, le pediremos a @taker59 que lo pruebe también en un entorno real por si nos volvemos a cargar su router (pobrecillo, es un conejillo de indias).

 

@David B me remito a lo que he comentado a Toni


Hola Theliel,

 

 tengo la B21.

 

Un saludo

Mensaje 100 de 991
1.600 Visitas