Túneles IPSec (VPN - Error 800) con router Mitrastar GPT-2541GNAC

Túneles IPSec (VPN - Error 800) con router Mitrastar GPT-2541GNAC

Buenas noches:

 

A ver, llevo tooo el día intentando configurar la VPN de mi casa para acceder desde fuera hacia casa con una VPN.

 

He intentado de todo, cuando tenia Vodafone, el router no me daba tantos problemas como la castaña pilonga de router nuevo que me han puesto que tiene más seguridad que el Presidente Obama.

 

Ya no se que puertos abrir, ni que tuneles clausurar ni nada, y se me están inflando mis pelotas de mayorista.

 

Puertos 500, 1723 y 47 abiertos.

Firewall LAN y WAN desactivados en el router

Firewall windows 7, tirado abajo por si acaso.

 

Y ya no se que hacer, cuando intento conectar me da error 800 VPN de tunel.

 

¿Alguien me puede ayudar, por favor?

Mensaje 1 de 66
13.889 Visitas
65 RESPUESTAS 65

Un portatil sin toma de red??? Debe de ser muy muy viejo, desde años inmemorables los tienen.

 

En realidad con que tengas nociones básicas, puedes perfectamente hacer las capturas y me las mandas por privado si quieres y las veo. Eso si... a poder ser:

 

a) Con todo cerrado, navegador apps y otros, para minimizar el ruido

b) La primera, con DMZ, logrando correctamente la conexión. Empiezas a capturar, haces la conexión, una vez esté la conexión establecida no es necesario navegar ni nada, cortas la conexión VPN y detienes la captura

c) La segunda quitas DMZ, repites operación anterior. Fallará... espera unos 10 segundos o así, pruebas de nuevo... volverá a fallar. Detienes captura.

 

Generas los dos archivos y me los mandas por privado si quieres.

 



Por privado solo asuntos privados, para lo demás la comunidad."El conocimiento nace del desacuerdo"
Mensaje 51 de 66
10.557 Visitas

@Theliel ¿Con los colores de la pantalla , esas lineas que van saliendo en el wireshark ya se saben los puertos? Hace eones que no lo uso.

 

Con respecto a la edad del portatil de mi padre, la verdad es que lo desconozco, no creo que sea muy viejo, tiene lector de huellas biométricas, lo que pasa es que es un ultrabook de esos y no lleva RJ45 hembra, eso ya lo desconozco.

 

Saludos.

Mensaje 52 de 66
10.548 Visitas

Si, jajaja, todos esas líneas indican no solo puertos, sino mucho mas. Se puede seguir la "conversación" que mantienen servidor-cliente, ver en que punto de esa conversación se corta, ver si uno de los dos se queda esperando respuesta... como se ejecuta en el PC, se tiene siempre el punto de vista de este, es decir... sabemos lo que el pc manda y lo que el PC recibe, no lo que el servidor de ellos les llega al final o lo que ellos envían realmente.

 

No obstante, aun con todo, es tremendamente útil para diagnosticar cualquier tipo de problema de red. Por ejemplo, si fuese un problema de puertos, mirando la negociación de uno y de otro cantaría a la legua. O podría ser que no fuese un problema de puertos y que simplemente el portatil esté haciendo algo raro.

 

Lo mismo puede hacerse incluso desde el punto de vista del Router, es decir... eejcuta el analizador directamente sobre el Router, pero no vamos a entrar en eso ahora 😉



Por privado solo asuntos privados, para lo demás la comunidad."El conocimiento nace del desacuerdo"
Mensaje 53 de 66
10.533 Visitas

Una cosa @lfcpotter ... indicas que desde tu portatil conectando por cable ethernet y con el DMZ desactivado ¿Conectas a la VPN de tu padre  o a la tuya? lo digo por aclarar el tema ya que tu padre me comentó en su momento que tiene un certificado en su PC y que sin él no se puede conectar a la VPN nadie.

 

Hay algunos equipos como los ultrabook o los Macbook que no traen ethernet....   😞

 

Sería necesario que probaséis con otro equipo, como por ejemplo tu portatil, a conectar por cable y por wifi y ver si difieren los resultados.



Si necesitas soporte técnico en averías de Móvil, Fijo, Movistar+ o Internet Fijo (cobre o fibra), puedes acceder a nuestro apartado de Soporte Técnico o rellenar este formulario. También puedes contactar con nosotros llamando al 1002.

 Si necesitas contratar Fibra Ópticacomprobar tu cobertura Adsl y Fibrao ver información sobre la instalación de la fibra visita nuestra página ADSL y Fibra en movistar.es 

Solución aceptada.png
Mensaje 54 de 66
10.526 Visitas

Buenos días Julio,

 

Soy el padre de @ifcpotter. Me acabo de registrar para poder comentarte y responderte en pesona. Por nuestros horarios, coincido poco rato con mi hijo.

 

Intento responderte:

  1. Mi portatil es un ultrabook de HP, sin conector RJ45, pero me van a facilitar un conector para probar. Te diré el resultado entre las 14 y 15 h
  2. Con mi portatil y DMZ, funciona perfectamente. Sin DMZ no funciona.
  3. Con el portatil de mi hijo podemos conectar a mi VPN, SI ESTA CONECTADO AL ROUTER POR CABLE. Con Wifi tampoco conecta y tenemos el famoso error 800
  4. El certificado de empresa que tengo instalado en mi portatil se usa, de forma transparente para el usuario, en determinadas comunicaciones por mail, pero me aseguran que NO AFECTA PARA NADA a la conexión de VPN.
  5. Conexión que resumiento es PPTP, y sólo necesita 1723 tcp y 47 tcp

Muchas gracias por tu ayuda!:

Mensaje 55 de 66
10.522 Visitas

Ok, gracias @ifa quedo a la espera de la prueba por cable con el ultrabook. Probar por favor con y sin DMZ.



Si necesitas soporte técnico en averías de Móvil, Fijo, Movistar+ o Internet Fijo (cobre o fibra), puedes acceder a nuestro apartado de Soporte Técnico o rellenar este formulario. También puedes contactar con nosotros llamando al 1002.

 Si necesitas contratar Fibra Ópticacomprobar tu cobertura Adsl y Fibrao ver información sobre la instalación de la fibra visita nuestra página ADSL y Fibra en movistar.es 

Solución aceptada.png
Mensaje 56 de 66
10.519 Visitas

Buenas @JulioC-Movistar

 

Me he agenciado un conector USB a RJ45 

Conectado por cable al router, (y desconecto el Wifi) realizo las pruebas solicitadas.

Resultados:

   . Con DMZ sigue funcionando sin problemas

   . Sin DMZ me retorna error 806

 

Ya me dirás, muchas gracias y buen fin de semana

Mensaje 57 de 66
10.514 Visitas

Con eso queda descartado un problema de interfaz wifi, ya que por cable sigue fallando, sigo pensando que es un tema de un puerto que no se abre ya que con DMZ funciona correctamente. Lo que ocurre es que se me han acabado las balas... Si con UPnP tampoco funciona.... ya no se me ocurre nada para evitar usar el DMZ, aunque siempre se puede usar puntualmente, activandolo y desactivandolo según el uso.



Si necesitas soporte técnico en averías de Móvil, Fijo, Movistar+ o Internet Fijo (cobre o fibra), puedes acceder a nuestro apartado de Soporte Técnico o rellenar este formulario. También puedes contactar con nosotros llamando al 1002.

 Si necesitas contratar Fibra Ópticacomprobar tu cobertura Adsl y Fibrao ver información sobre la instalación de la fibra visita nuestra página ADSL y Fibra en movistar.es 

Solución aceptada.png
Mensaje 58 de 66
10.511 Visitas

Buenas @JulioC-Movistar

 

A mi padre que se ha registrado , le da error 806 al intentar acceder con la VPN que tiene ya creada, y si le da a crear una nueva, apuntando a la misma ip y demás, da el maldito error 800 de tuneles. 

 

Con la DMZ si que funciona todo, pero claro, si mi padre pone su IP a mi me deja de funcionar mi VPN servidor, por eso lo deshabilitamos para que a mi me funcione.

 

Probaremos este fin de semana en un rato a instalarle el wireshark a mi padre y a hacer lo que @Theliel indica, probar a conectarnos y pasarle las capturas de pantalla por privado a ver si ve que puerto extraño pudiera estar utilizando, ya que en el router el 1723 TCP para su ip esta abierto y el 47 en teoría también.

 

Cualquier novedad la vamos escribiendo aquí.

 

Saludos.

Mensaje 59 de 66
10.509 Visitas

@Ifcpotter

 

No tienes que abrir ningún puerto para usar un cliente VPN, el puerto 1723 es para usarse en el servidor VPN, no para un cliente. Para un cliente no tiene que abrir nada, y el 43 es un protocolo, no es un puerto. Digo esto para que no te lies.

 

Por otro lado, viendo que aun tienes DMZ en el tuyo eso puede ser un problema. Has probado a deshabilitar DMZ en el Router (no poner ningún equipo) y ver si así funciona como cliente VPN el de tu padre?? Lo digo porque al establecer un equipo como DMZ, todo el tráfico entrante no solicitado, incluso el que el Router identifique como VPN lo va a pasar al equipo DMZ, a menos que se mapeen puertos. De ahí entre otras muchas cosas DMZ no es recomendable para nadie. Es decir... lo que te digo que pruebes es que quites DMZ, a ningún equipo, y pruebes de nuevo la conexión PPTP de tu padre.

 

Por otro lado, eso sí, asegurate que el Router tiene una entrada en portforwarding para el 1723 A TU SERVIDOR para que funcione, pero no al de tu padre



Por privado solo asuntos privados, para lo demás la comunidad."El conocimiento nace del desacuerdo"
Mensaje 60 de 66
10.507 Visitas

@Theliel

 

Si si, las pruebas ya las hemos hecho como comenta mi padre más arriba, con el DMZ activado a el le va bien conectarse desde su portatil al trabajo, pero entonces me fastidia a mi mi conexion VPN.

 

Por eso por ahora lo hemos deshabilitado. Como decia @JulioC-Movistar una solución "incompleta" es activar y desactivar el DMZ cuando se vaya a usar, pero eso es muy incomodo, debería funcionar la VPN sin problemas a él.

 

Tiene el firewall desconectado y demás y a mi padre no le va, en cambio a mi si, como ya he comentado, desde mi ordenador por cable me conecto a su VPN con sus datos y entra a la primera sin el DMZ, pero a él, ni siquiera le va con el cable, por eso es rarisimo.

 

Salvo que se te ocurra algun milagro u otro arte de birlibirloque tendremos que hacer el wireshark.

 

Saludos.

Mensaje 61 de 66
10.505 Visitas

Pues es muy raro.

 

Técnicamente hablando, lo único que hace DMZ es eso, enviar todo el tráfico a un equipo concreto a menos que exista uan regla superior que especifique otra cosa. Tu equipo funciona bien como cliente sin DMZ, que es lo normal y como debe de ser, así que el usar DMZ hacia su equipo y que así funcione no tiene en principio mucha lógica.

 

Lo único que se me ocurre es que el Router tenga alguna regla o filtro que se haya puesto sin querer/queriendo y esté interfiriendo de algún modo,

 

Mira a ver si puedes con Wire, y sino también podríamos ponernos de acuerdo un día/hora y hacer una sesión de TeamViewer al equipo de tu padre y desde ahí ver que está pasando



Por privado solo asuntos privados, para lo demás la comunidad."El conocimiento nace del desacuerdo"
Mensaje 62 de 66
10.501 Visitas

Estimados @JulioC-Movistar y @Theliel

 

Después de seguir trasteando toda la tarde con este asunto, os comunico que ya está solucionado!

Puedo conectar a la VPN del trabajo en las mismas condiciones que lo hacia, con Firewall y antivirus activado.

 

Dejo a mi hijo @Ifcpotter que os cuente como ha surgido la solución.

 

Por mi parte agradeceros vuestra desinteresada ayuda y ... , (no se si estoy saltándome alguna norma del foro que aún no he leído, y pido disculpas por anticipado, pero por mi parte...),   si pasais por Zaragoza y me avisáis, unas cervezas y unas tapas van de mi cuenta.

 

 Muchas gracias por todo.

Mensaje 63 de 66
10.484 Visitas

Buenas tardes @JulioC-Movistar@Theliel

 

Tal y como ha dicho mi padre en el mensaje anterior, por fiiin hemos solucionado los problemas de la VPN.

 

La historia comienza cuando trasteando con el router, hemos llegado a un punto en el que lo hemos bloqueado sin querer, y tras llamar al 1002, la única solucion era reiniciarlo con un palillo por detrás.

 

Hemos perdido la configuración de puertos y demás, pero con un poco de paciencia, y buena memoria que poseo, he vuelto a poner todos los puertos que teniamos a las distintas IPs, así como activar el UPnP por si acaso y deshabilitar el firewall del FTP.

 

Trás realizar de nuevo todos los pasos anteriores, la VPN servidor de mi portatil habia quedado restaurada sin mayor problema.

 

Y llegamos a la parte cliente de mi padre, cuando ibamos a instalar wireshark para ver que fallaba, primero hemos intentado acceder a ver que pasaba, y tocate las narices! FUNCIONA! sin hacer nada...

 

Creemos que se debería a algún toquitiñeo raro en el router que ya no pudimos o supimos deshacer, y que al reiniciarlo de fábrica se ha eliminado, lo que ha provocado que funcione como debería.

 

Así que, en resumen, la solución de todo este tema, estaba en la punta de un palillo  

 

Si venís por Zaragoza me apunto a las cervezas! 😉

 

Un saludo y muchísimas gracias a los 2 !!

Mensaje 64 de 66
10.478 Visitas

No hay de que @Ifcpotter y @ifa

 

Tenía que ser algo así, como decía alguna regla en el FW que se había metido o cualquier ajuste que estaba haciendo de las suyas. En cualquier caso estoy seguro que todos los presentes se alegran de ello.

 

Buena tierra aquella, buena gente. Apuntado queda.

 

saludos.



Por privado solo asuntos privados, para lo demás la comunidad."El conocimiento nace del desacuerdo"
Mensaje 65 de 66
10.476 Visitas

Me alegro de que ya funcione correctamente, normalmente el reset suele ser lo primero que acometo.... error mio en este caso que lo di por supuesto que ya lo habíais intentado y no os funcionó...  😞   nos hubiesemos ahorrado unos cuantos posts   🙂  y preocupaciones.      🙂

 

Gracias a vosotros por las pruebas y también a @Theliel por su inestimable ayuda, un saludo desde Bilbao.   🙂

 

Lo doy por solucionado y cierro el hilo.



Si necesitas soporte técnico en averías de Móvil, Fijo, Movistar+ o Internet Fijo (cobre o fibra), puedes acceder a nuestro apartado de Soporte Técnico o rellenar este formulario. También puedes contactar con nosotros llamando al 1002.

 Si necesitas contratar Fibra Ópticacomprobar tu cobertura Adsl y Fibrao ver información sobre la instalación de la fibra visita nuestra página ADSL y Fibra en movistar.es 

Solución aceptada.png
Mensaje 66 de 66
10.402 Visitas